partclone restore exit error

Over the last three years I have made a lot of disk clones with clonezilla. I did this before reinstalling another OS or just to backup, but I always did it quickly. That means I just cloned the disk and never looked at it again. I only had to restore two or three times.

The problem is that because I did not really document anything about what is in the image, I now have no clue if I still want to keep image X or image Y. I need to see what is in the images…

So I’m restoring¬† images by cat’ing together the compressed pieces of my images and decompressing them and piping that stream into partclone restore utility.

Now I keep getting this very obscure error:
Partclone v0.2.80 http://partclone.org
Starting to restore image (2013uncompressed.img) to device (2013.iso)
UID is root.
source=2013uncompressed.img, target=2013.iso
open source file/device 2013uncompressed.img
open target file/device 2013.iso
device (2013.iso) is mounted at
error exit

I have no clue what to do with that. So I downloaded an old version of clonezilla that contained the same version of partclone that the cloned image was made with. That gave the same error. Then I found an answer on askubuntu with zero rating. Just create the file first before you issued the partclone.restore. So to summarize:

touch /dir-to-new-image/partition.img
sudo cat /dir-to-images/partitionname.gz.* | sudo gzip -d -c | sudo partclone.restore -C -s - -O /dir-to-new-image/partition.img

So in the end this was super easy and I did not even need a clonezilla live usb. I could just do this from arch linux using partclone 2.80.

Thanks to: